Jump to content
Not connected, Your IP: 3.216.79.60
Staff

Call for tests and opinions

Recommended Posts

Hello!

 

We need to understand if some advanced feature of AirVPN client can be activated by default for all users without causing issues.

We ask those who want to collaborate to do a little test:

In Menu -> Preferences -> Advanced -> General please enable
"Checking if the tunnel uses AirVPN DNS" and "Force DNS" (this last option only under Microsoft Windows)

DNS Switch mode is by default set to "Automatic", please use it in "Automatic".

If these settings work for you, please use them and confirm in this topic that they work for you.
Otherwise, if some problem occurs, please describe here the problem.

 

Finally, we have a question: without prejudice to the fact that it can be switched on or off anytime by users, do you prefer that by default the option "Exit confirmation" is on or off?

Thanks to anyone who will collaborate!

 

Kind regards

AirVPN Staff

 

Share this post


Link to post

I made this test earlier, and it doesn't work that way on several linux systems. I did spent some serious time solving this. The only way to avoid the disconnection/ting loop is to uncheck both options in the airvpn client. I think the openvpn set-up has to be changed to de/increase the basic and default "cheching route time" in the openvpn software.

Share this post


Link to post

Works under OS X 10.9.4. I've used this option with the previous client and now also with 2.5 No problems for me. 

 

On the exit confirmation question, I actually don't have a strong opinion. I rarely quit the client so I rarely see that window anyway but in principle I think I'd rest on the side of caution and leave the confirmation prompt as the default option.

Share this post


Link to post

In Menu -> Preferences -> Advanced -> General please enable

"Checking if the tunnel uses AirVPN DNS" and "Force DNS" (this last option only under Microsoft Windows)

 

DNS Switch mode is by default set to "Automatic", please use it in "Automatic".

 

First, about the exit confirmation I personally dont care but I can see how that would annoy some people.

 

I have been using those 3 settings above for the past 3 Eddie releases and it has always worked. Windows 7 64. I should also point out, not sure if it matters, but in addition I have "force tap interface up," "switch dhcp to static," and "checking if tunnel effectively works" also enabled.

Share this post


Link to post

Hello,

 

Regarding exit confirmation= user choice is always best, I prefer off.

 

Have all settings enabled except enable pinger outside tunnel during connection and switch DHCP to static, working fine on W7 prox64 and W8.1.1 x64

Share this post


Link to post

No good here!

 

I tested accordingly:  First I dropped my private UFW rules to take it out of consideration.  Next I configured the client as you mentioned, which was to verify the tunnel and "automatic" in expert mode.

 

The connection was immediate and smooth using Linux 14.04.  I launched FF and went to check2ip dot com and ran a test.  My ISP's dns showed up all over the place.  Reminder; I am not using the network lock on 2.5.  Of course that ISP dns would be an issue.

 

Next I set the 2.5 client back to "renaming" in Linux instead of automatic.  I re-booted everything and still left my UFW firewall down.  I again launched FF, and this time as usual, ONLY Air dns shows up on all the tests I conduct.

 

I don't know if having the network lock OFF invalidates this test for what you want.

 

At this time I am running again with the client set to "renaming" and NOT automatic.  And as a reminder; due to my intra net concerns I have also enabled UFW again.  All is well.

 

I hope this helped because many Ubuntu users here will not be employing a UFW firewall on their own.  The automatic setting doesn't work on 14.04 for my machine.

 

I will run the exit confirmation OFF and I don't care which default you use as long as I have the option to set it how I like.

Share this post


Link to post

Exit confirmation: Options are good, I prefer it on (i'm an idiot and have hit the X instead of the - once or twice by mistake while connected), but don't really care what the default is so long as there is an option.

 

"If these settings work for you, please use them and confirm in this topic that they work for you."

---

win64-7\2008r2: They do seem to work as expected, I just don't have a need to have them enabled in most of my evironments.

 

win64-7\2008r2 - Force DNS - No thanks, this should be off by default in my opinion, I don't want airvpn touching the dns settings (or any settings for that matter) of non-tunnel adapters on my system(s) without me explicitly telling it to do so; same reasons I suppose I will not use network lock, I've already configured rules of my own (that I touch at times while connected and those changes would be lost), I get that these feature maybe make life easier for the average joe at home though so they're good to have as options.

 

/2cents

Share this post


Link to post

No good here!

 

I tested accordingly:  First I dropped my private UFW rules to take it out of consideration.  Next I configured the client as you mentioned, which was to verify the tunnel and "automatic" in expert mode.

 

The connection was immediate and smooth using Linux 14.04.  I launched FF and went to check2ip dot com and ran a test.  My ISP's dns showed up all over the place.  Reminder; I am not using the network lock on 2.5.  Of course that ISP dns would be an issue.

 

Hello!

 

That's fine: it is a correct behavior. If you have your router DNS server set as nameserver in your resolv.conf Network Lock will not block DNS queries to your router, that's not its purpose at the moment (it explicitly allows communications to your router otherwise your system would be completely isolated even in the local network). So Network Lock ON or OFF in this case makes no difference and the fact that you could see your ISP DNS shows that the system works as expected and according to your configuration.

 

Next I set the 2.5 client back to "renaming" in Linux instead of automatic.  I re-booted everything and still left my UFW firewall down.  I again launched FF, and this time as usual, ONLY Air dns shows up on all the tests I conduct.

 

I don't know if having the network lock OFF invalidates this test for what you want.

 

At this time I am running again with the client set to "renaming" and NOT automatic.  And as a reminder; due to my intra net concerns I have also enabled UFW again.  All is well.

 

And that's correct again. No issues on the client so far, it is behaving exactly as you instructed it to.

 

 

I will run the exit confirmation OFF and I don't care which default you use as long as I have the option to set it how I like.

 

Of course, testing this particular configuration on a variety of systems is totally voluntary! From your description everything is fine, thank you for your time, it is very much appreciated.

 

Kind regards

Share this post


Link to post

Works on testmachine (Win7 x64) without problems. I think the exit confirmation is a good thing and should be enabled by default.

Advanced users could turn it of if they feel like it. Its a good feature for beginner users...

Share this post


Link to post

As Lyaios said: works fine with 10.9.4.

Exit confirmation? 

Hmm strange I've never seen this prompt? And yes it is enabled in my settings. Maybe this is the problem for my last post

 

But yes it should be enabled by default!

Share this post


Link to post

In Menu -> Preferences -> Advanced -> General please enable

"Checking if the tunnel uses AirVPN DNS" and "Force DNS" (this last option only under Microsoft Windows)

 

DNS Switch mode is by default set to "Automatic", please use it in "Automatic".

 

If these settings work for you, please use them and confirm in this topic that they work for you.

Otherwise, if some problem occurs, please describe here the problem.

 

It is working here on Windows 8 x64.

Share this post


Link to post
Posted ... (edited)

I have been using Eddie 2.2-2.4 on Windows 7 x64. I have always ensured that those three settings have the values you have described. I have never had any issues on Windows.

 

I have been using the Mac versions since it was released. With same setting's values set as mentioned. I have had a mixed experience on OSX 10.9.something. The client connects successfully when the app is first started. But if for some reason the connection is lost, it gets stuck in the connect-disconnect-reconnect loop. Doesn't always happen. Quitting the app, ensuring the Wifi DNS is not set to AirVPN DNS and starting app seems to resolve it.

 

Regarding the Exit Confirmation - Huge NO. On my Windows machine I hibernate it a lot. If AirVPN is running when the machine is put into hibernation, on resuming the Servers tab gets badly glitched. Its constantly keeps refreshing itself making it impossible to select a server. Point being I quite the app a lot. Also if I forget to quit app and I try to shutdown/restart the machine, it simply WONT proceed further till I cancel the shutdown, answer yes and try again. Very frustrating.

 

I prefer the confirmation prompt to NOT be enabled by default. If as a user I need something like this, I would ask in the forums and get redirected to the appropriate settings tab.

Edited ... by strideram

Share this post


Link to post

One reason the exit confirmation option means very little to me is that I create a bridge using linux to host Air as vpn1.  When I am closing a TOR browser during a session its a couple of VM's down the line.  I only close the Air bridge right before I shut down the machine.  All other internet action and virtual machines have been halted by then.

 

Unrelated note:

 

Staff  ---   this is unrelated but it just dawned on me that it literally has been many months since Air dropped my circuit.  I can't remember it at all in fact.  On my strict setup if the VPN connection dropped I would have to manually raise the bridge again.  Never happens.

 

Air = Dependable as can be!!!!!!  Thank you for that!!!!

Share this post


Link to post

In Menu -> Preferences -> Advanced -> General please enable
"Checking if the tunnel uses AirVPN DNS" and "Force DNS" (this last option only under Microsoft Windows)

DNS Switch mode is by default set to "Automatic", please use it in "Automatic".

 

I routinely use these settings without a problem running Windows 7-64 and Fedora 20.

 

I appreciate that the current version of Eddie has the Exit Confirmation as an option.   I don't care what the default setting is, as long as I can turn it off.

 

Thank you!!!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...