Jump to content
Not connected, Your IP: 18.232.188.251
Sign in to follow this  
stupidcats

AirVPN client in Linux (ubuntu) - Some questions

Recommended Posts

Hey there,

 

So I'm using the AirVPN client on ubuntu and I've two questions:

 

1) How do I make it so the client starts at system startup?

 

I already added "sudo airvpn" to the system-startup thing and in the airVPN client I checked the box "Connect at startup". It's still not working.. Any idea why?

 

2) What's the name of the process in the system-monitor?

 

The other day I had a problem with the client and couldn't/didn't-know-how-to kill it because I couldn't find the process..

Share this post


Link to post

Hey there,

 

So I'm using the AirVPN client on ubuntu and I've two questions:

 

1) How do I make it so the client starts at system startup?

 

I already added "sudo airvpn" to the system-startup thing and in the airVPN client I checked the box "Connect at startup". It's still not working.. Any idea why?

 

Hello!

This guide can help you: http://askubuntu.com/questions/30931/how-do-i-make-a-program-auto-start-every-time-i-log-in

 

 

2) What's the name of the process in the system-monitor?

 

The other day I had a problem with the client and couldn't/didn't-know-how-to kill it because I couldn't find the process..

 

You can find out the PIDs of the various airvpn processes with

 

ps aux | grep airvpn

 

Kind regards

Share this post


Link to post

 

Hey there,

 

So I'm using the AirVPN client on ubuntu and I've two questions:

 

1) How do I make it so the client starts at system startup?

 

I already added "sudo airvpn" to the system-startup thing and in the airVPN client I checked the box "Connect at startup". It's still not working.. Any idea why?

Hello!

This guide can help you: http://askubuntu.com/questions/30931/how-do-i-make-a-program-auto-start-every-time-i-log-in

 

Hello,

 

Respectfully, I don't think your link helps me, as airvpn requires sudo.. As I said in OP, I already did what that link says, but it's not working.

 

Thank you for the point 2 though, it helped.

Share this post


Link to post

 

 

Hey there,

 

So I'm using the AirVPN client on ubuntu and I've two questions:

 

1) How do I make it so the client starts at system startup?

 

I already added "sudo airvpn" to the system-startup thing and in the airVPN client I checked the box "Connect at startup". It's still not working.. Any idea why?

Hello!

This guide can help you: http://askubuntu.com/questions/30931/how-do-i-make-a-program-auto-start-every-time-i-log-in

 

Hello,

 

Respectfully, I don't think your link helps me, as airvpn requires sudo.. As I said in OP, I already did what that link says, but it's not working.

 

 

Hello!

 

Of course your method fails. If you have already tried "ps" you will have already seen how to run AirVPN properly and elevate privileges in a graphical environment. If not, just look at how "AirVPN.exe" is run.

 

Kind regards

Share this post


Link to post

Hey!

Hello!

 

Of course your method fails. If you have already tried "ps" you will have already seen how to run AirVPN properly and elevate privileges in a graphical environment. If not, just look at how "AirVPN.exe" is run.

 

Kind regards

 

I've edited the sudoers file by doing

sudo visudo
 

and then adding the following to the file:

epsilon ALL = NOPASSWD: /usr/lib/AirVPN/AirVPN.exe
 

I also tried other paths, such as /usr/bin/X11/airvpn and /usr/bin/airvpn but neither worked.

 

What am I doing wrong?!

Share this post


Link to post

Hello!

 

sudo can't be used to elevate privileges of a program in a graphic environment. The client can run in non-graphic mode but in this case you must specify "-cli" option.

 

With ps ("ps ax | grep airvpn"), have a look at how you can run AirVPN client Eddie on your environment (after you have launched the client through your desktop manager launcher).

 

Kind regards

Share this post


Link to post

hello! How can I add AirVPN client - eddie 2.88 as a startup apllication on ubuntu? I tried all of the above but none worked.

 

Thanks!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

×
×
  • Create New...