Jump to content
Not connected, Your IP: 34.237.76.91
HugeHedon

Ubuntu/Linux: How to use NetworkManager for AirVPN

Recommended Posts

I believe I went a bit far with my criticism in my last post. I also should have followed procedure. I was venting out of pure frustration and would like to apologize. The problem is not quiet solved yet, but I am getting support and have some hope again. I should have remembered that with issues like this, patience is the name of the game. As hard as that sometimes is. LOL.

Share this post


Link to post

I believe I went a bit far with my criticism in my last post. I also should have followed procedure. I was venting out of pure frustration and would like to apologize. The problem is not quiet solved yet, but I am getting support and have some hope again. I should have remembered that with issues like this, patience is the name of the game. As hard as that sometimes is. LOL.

Hello!

No worries, you're welcome. Support has been moved to e-mail for faster feedbacks.

Kind regards

Share this post


Link to post

Hi,

Thanks for the tutorial! However, I am still having issues despite following your directions and reading this entire thread.

I'm running Ubuntu 11.10 on a virtual machine and my first attempt was using Tor proxy settings but that did not work so I went back and generated a configuration file for port 80 UDP. Followed the steps, rebooted, started openvpn service in terminal, tried to connect, and timed out.

I also added the 4 configuration files to /etc/openvpn as suggested earlier in this thread. Any help with this problem would be helpful, thanks.

Share this post


Link to post

Hi,

Thanks for the tutorial! However, I am still having issues despite following your directions and reading this entire thread.

I'm running Ubuntu 11.10 on a virtual machine and my first attempt was using Tor proxy settings but that did not work so I went back and generated a configuration file for port 80 UDP. Followed the steps, rebooted, started openvpn service in terminal, tried to connect, and timed out.

I also added the 4 configuration files to /etc/openvpn as suggested earlier in this thread. Any help with this problem would be helpful, thanks.

Hello and thank you for your choice!

A TCP port is mandatory to connect over TOR (or over any SOCKS and http proxy). Quickest solution: edit your air.ovpn configuration file and change the line

proto udp
to
proto tcp
.

Also, make sure that the socks-proxy line is included with the proper settings.

In case of doubt, re-generate your configuration with our configuration generator available here:

https://airvpn.org/index.php?option=com_air&view=access&Itemid=100

and make sure to select the appropriate proxy type and its IP address and port number.

For AirVPN over TOR connections detailed example, please see also https://airvpn.org/index.php?option=com_content&view=article&id=64&Itemid=122

Please do not hesitate to contact us for any further information.

Kind regards

Share this post


Link to post

Hi All,

I'm new here. I configured and connect without any problems with VPN but I dont have internet right now. When I will disconnect VPN - internet works fine. Any suggestions?

Forgot to write I am using ubuntu 11.04

Share this post


Link to post

Hi All,

I'm new here. I configured and connect without any problems with VPN but I dont have internet right now. When I will disconnect VPN - internet works fine. Any suggestions?

Forgot to write I am using ubuntu 11.04

Hello!

We would need additional information to give you proper support. Can you please send us:

- the connection log

- the output of the command ifconfig -a when you're disconnected and when you're connected (in private, if it may compromise your privacy).

We're looking forward to hearing from you.

Kind regards

Share this post


Link to post

And where is the connection log? How to send private message here?

Funny thing is that on "My details" tab - there is info:

You totally downloaded 155 kB and uploaded 116 kB in 2120 seconds while staying with us,

Maybe I should add some IP filtering on my router?

Share this post


Link to post

Hi, I'm using linux mint.

I'm not used to using linux at all, but I think I installed openVPN through the software manager. Downloaded the access without our client package.

This part of the instructions "Perhaps you'll have to log out and log in again, or even restart the computer or something. To check that openvpn plugin was properly installed in NetworkManager, click on the nm-applet (the NetworkManager icon) => VPN Connections => Configure VPN. In the little window that comes up, click the Add button. Is there an OpenVPN option in the menu? Good. But don't click on it. Just close the windows. This was just a check."'

I didn't see "openVPN" option there, but when I tried installing openVPN again, it said it was already installed.

I went ahead and continued. Made sure LZO data compression was checked.

When I go to the menu and click VPN, "air" shows up, but when I click it, it immediately says

"VPN connection 'air' failed because there were no valid VPN secrets?"

Share this post


Link to post

Hi, I'm using linux mint.

"VPN connection 'air' failed because there were no valid VPN secrets?"

Hello!

Please make sure that key, certificates and configuration files (that is, the files that you find inside the air.zip generated by our configuration generator) are in the correct path and that they have the correct access permissions.

Also, if you could send us the OpenVPN logs they could greatly help the troubleshooting.

Kind regards

Share this post


Link to post

Problem solved with restarting computer, based on this thread at ubuntu forums (http://ubuntuforums.org/showthread.php?t=1564642) that simply restarting the computer was sufficient. It works now.

The terminal command "sudo /etc/init.d/network-manager restart" mentioned in that thread did not for whatever reason.

As far as sending you the OpenVPN logs, I'm afraid I'm such a newbie at linux that I don't know how to do that.

Share this post


Link to post

Problem solved with restarting computer, based on this thread at ubuntu forums (http://ubuntuforums.org/showthread.php?t=1564642) that simply restarting the computer was sufficient. It works now.

The terminal command "sudo /etc/init.d/network-manager restart" mentioned in that thread did not for whatever reason.

As far as sending you the OpenVPN logs, I'm afraid I'm such a newbie at linux that I don't know how to do that.

Hello!

We're glad to know that you solved the problem.

If/when you need to view logs, you can edit the configuration file with any text editor and add the directive "log-append /to/air.log>" to easily generate and find the OpenVPN logs.

Kind regards

Share this post


Link to post

I get to this step:

 

Ok, this should be it. Click OK, Apply, Close etc.

 In Linux Mint, there is a "save" button which is like "apply" but it is grayed out. All I can do is click the 'x' to close the window and nothing shows up?

 

Also, there is no zip file when I download the configuration is it an .ovpn file which opens just fine after clicking "import" but like I said, I cannot "save" the configuration.

Share this post


Link to post

I get to this step:

 

 In Linux Mint, there is a "save" button which is like "apply" but it is grayed out. All I can do is click the 'x' to close the window and nothing shows up?

 

Also, there is no zip file when I download the configuration is it an .ovpn file which opens just fine after clicking "import" but like I said, I cannot "save" the configuration.

 

Hello!

 

Now you can pick the compression format of the archive to download, or no compression at all (the compression options will not be prompted if only one file is generated). Please make sure you have followed the below steps reported in the instructions, because network-manager does not support embedded .ovpn files:

  • Select "Advanced Options"
  • Tick "Separate certs/keys from .ovpn files"

Kind regards

Share this post


Link to post

Hello!

 

Now you can pick the compression format of the archive to download, or no compression at all (the compression options will not be prompted if only one file is generated). Please make sure you have followed the below steps reported in the instructions, because network-manager does not support embedded .ovpn files:

  • Select "Advanced Options"
  • Tick "Separate certs/keys from .ovpn files"

Kind regards

It looks like I did miss the "Advanced Options", it made the correct output following that step, thanks.

 

For anyone else using Mint, it is slightly different in that to turn it on after saving the configuration, you go to Menu > Preferences > Network, look for AirVPN in the left-side pane, click and slide the button to "On."

Share this post


Link to post

It looks like I did miss the "Advanced Options", it made the correct output following that step, thanks.

 

For anyone else using Mint, it is slightly different in that to turn it on after saving the configuration, you go to Menu > Preferences > Network, look for AirVPN in the left-side pane, click and slide the button to "On."

 

Sorry to hear that, but I think it is easily done - I had the same problem at first with Ubuntu 13.04.

 

The trouble is, I think, caused by the way the instructions are laid out (and me being a bit too clever for my own good). In my case, I jumped straight over the "Using AirVPN with Linux" section to the "Using AirVPN with Ubuntu NetworkManager" section and then started tearing my hair out when I could not find out about how the mentioned ZIP file was to be generated!

 

I think a step mentioning the "Advanced Options" again between the lines -

  • "Create an AirVPN account. Generate...."

and

  • "Save the downloaded zip-file....."

would have saved me an hour of pain.....

 

...that, or reading your post beforehand  

 

Thanks Staff for the info

Share this post


Link to post

Hi Guys,

 

I have installed Debian "Jessie" (testing) and I have tried to follow the instructions for linux on the site to install openvpn settings etc. Everything was fine until I came across the option to import openvpn this isn't an option in Jessie it just gives me option to manually input everything. So how do I do this? what would be the proper way? could there be a script to import it ?

I have attached images to show what I am talking about.


Share this post


Link to post

@monway

 

Hello!

 

In the Configuration Generator make sure that you select "Advanced Mode" and tick "Separate certs/keys from .ovpn files". In that way you will download separate files that you can use to configure your OpenVPN wrapper (first screenshot you sent us).

 

Server certificate: ca.crt

Client certificate: user.crt

Private key: user.key

 

user.key is not password-protected by default.

 

Kind regards

Share this post


Link to post

How about finding out the gateway address? to input on the wrapper *see picture above in my first post. above.

 

The default gateway is pushed by the OpenVPN server, is it possible to leave it blank?

 

Kind regards

Share this post


Link to post

 

How about finding out the gateway address? to input on the wrapper *see picture above in my first post. above.

 

The default gateway is pushed by the OpenVPN server, is it possible to leave it blank?

 

Kind regards

 For the situation I have used Jessie (Debian) and I have given up since it's "testing" so I have moved onto Ubuntu which works like a charm. On jessie I had to enter the ip address or else it wouldn't let me save. I just avoided running testing all together. all is well. Thank you guys.

Share this post


Link to post

@staff

Thanks for the hint about the "Advanced Mode" and "Separate certs/keys from .ovpn files".

It took me quite a while to find this tip, though. Could you please add this to https://airvpn.org/linux/ ? Otherwise that guide is excellent.

 

Hello,

 

excellent. Well, it's there (both on the Linux instructions and on the Config Generator help page) since months, maybe you missed it...

 

Kind regards

Share this post


Link to post

Hello staff,

 

I've recently bought a sub and used it on OS X without issues. When the time came to try it in linux (mint debian), I found the above NetworkManager guide and followed it step-by-step. After importing and double checking whether everything was done as said, I'm unable to connect. I've inputted my password for the airvpn.org website and tried both with and without it. The first few times I was getting "connection timeout" errors but now the connection just drops without ever establishing.

 

What can you suggest? Thanks.

Share this post


Link to post

Hello!

 

Have you generated separate files? You should have, in addition to .ovpn configuration files, ca.crt (server certificate), user.crt (client certificate) and user.key (client key).

 

The authentication is not based on login/password.

 

Kind regards

Share this post


Link to post

Hello!

 

Have you generated separate files? You should have, in addition to .ovpn configuration files, ca.crt (server certificate), user.crt (client certificate) and user.key (client key).

 

The authentication is not based on login/password.

 

Kind regards

 

Sorry to say but yes I have, what else can I do? Change server perhaps?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...