Jump to content
Not connected, Your IP: 3.94.129.211

Recommended Posts

I've readed almost every post in this forum about it and outside too but didn't managed to resolve. The problem is, i select Socks at config on AirVpn; Host : 127.0.0.1; Port 9150, then i start Tor, select the socks5 put the host and port and connect. But when i try to connect the AirVpn (Using TCP) it gives me this error everytime.

 

20/12/2013 - x:21 Login...
20/12/2013 - x:21 Login success.
20/12/2013 - x:21 Contacting service...
20/12/2013 - x:21 Connecting...
20/12/2013 - x:21 OpenVPN 2.3.2 i686-w64-mingw32 [sSL (OpenSSL)] [LZO] [PKCS11] [eurephia] [iPv6] built on Aug 22 2013
20/12/2013 - x:21 Socket Buffers: R=[8192->8192] S=[8192->8192]
20/12/2013 - x:21 Attempting to establish TCP connection with [AF_INET]127.0.0.1:9150
20/12/2013 - x:21 TCP connection established with [AF_INET]127.0.0.1:9150
20/12/2013 - x:21 socks_handshake: server asked for username/login auth but we were not provided any credentials
20/12/2013 - x:21 SIGTERM[soft,init_instance] received, process exiting
20/12/2013 - x:21 Failed to start.
 

Share this post


Link to post

Good afternoon Night , welcome. I've seen a bug for this on Trac recently with Tor 0.2.4.x. What version of Tor are you using?

The workaround for it was to add the following to the torrc file:

 

SocksPort 9150 PreferSOCKSNoAuth

 

 

Version 3.5 was released on the 18th and they are encouraging users to use this.

Share this post


Link to post

Good afternoon Night , welcome. I've seen a bug for this on Trac recently with Tor 0.2.4.x. What version of Tor are you using?

The workaround for it was to add the following to the torrc file:

 

SocksPort 9150 PreferSOCKSNoAuth

 

 

Version 3.5 was released on the 18th and they are encouraging users to use this.

 

Thanks for the answer, i use the version 3.5 of tor (The last one) but i still get this error. I went to "torrc-defaults" file and added the line "PreferSOCKSNoAuth" to the socksport line and then Tor just kept unexpectedly exiting until i got that line off. Dunno what to do now.

Share this post


Link to post
Posted ... (edited)

Edited : this vidalia log was about some bridge failing to connect, nothing to do with the socks problem, my apologies. Also thanks Am Nesty for poiting it out, i didn't knew it was about the bridge. but, the socks problem still unsolved.

Edited ... by Night

Share this post


Link to post

Any solution why vidalia keeps on exiting when i add the line SocksPort 9150 PreferSOCKSNoAuth  on torrc file? 

Share this post


Link to post

What version of Tor is that vidalia log from?

 

Based on that vidalia logs it looks like you are trying to conect to a bridge.

 

Can you connect without a bridge?

 

Have you tried a vanilla/default torrc?

 

I'm not sure what is going on, perhaps that will not help with the socks_handshake: issue

Share this post


Link to post
Posted ... (edited)
# If non-zero, try to write to disk less frequently than we would otherwise.

What version of Tor is the vidalia log from?

 

Are you trying to conect to a bridge?

 

Have you tried a vanilla/default torrc?

 

I'm not sure what is going on, perhaps that will not help with the socks_handshake: issue

AvoidDiskWrites 1
# Where to send logging messages.  Format is minSeverity[-maxSeverity]
# (stderr|stdout|syslog|file FILENAME).
Log notice stdout
# Bind to this address to listen to connections from SOCKS-speaking
# applications.
SocksListenAddress 127.0.0.1
SocksPort 9150 PreferSOCKSNoAuth
ControlPort 9151
CookieAuthentication 1
-----------------------------------------------------------------------------------------
 
I'm using the last version of vidalia. Version 3.5. I was using a bridge but lets forget this log from vidalia, i think it's not gonna help us on this socks problem. So, when i added the '"PreferSocksNoAuth" vidalia kept exiting unexpectedly. The solution was taking that string(?) off so vidalia could run normally again. Resuming didn't solvd my problem but i think we're close. any solution? any clue why vidalia exited unexpectedly when i added preferSocksNoAuth?
 
ps: i edited the post of vidalia log, you helped me out on the bridge problem thanks 
PS 2: thanks again for the help, but the problem stills, can you help me out, seems like it keeps on asking login/username and seems like the solutions was really the PreferSocksNoAuth  like you said but vidalia gives error and exit when i put PreferSocksNoAuth on torrc. any clue? thanks again for the help, very much appreciated.
Edited ... by Night

Share this post


Link to post

I was able to recreate this attempting to run VPN over Tor 3.5 (and Tor 0.2.4.18-rc-1).

However, I successfully ran VPN over Tor 0.2.3.25.

 

I suppose we'll need to look into it a bit further. Perhaps similar issues using SOCKS may arise?

Share this post


Link to post

A member of the Tor team was able to assist.  Try to change to the following in your torrc-default file:

 

# SocksListenAddress 127.0.0.1
# SocksPort 9150
SocksPort 127.0.0.1:9150 PreferSOCKSNoAuth

 

The solution lied in SocksListenAddress. This is from the man page:

 

SOCKSListenAddress IP[:PORT]

Bind to this address to listen for connections from Socks-speaking applications. (Default: 127.0.0.1) You can also specify a port (e.g. 192.168.0.1:9100). This directive can be specified multiple times to bind to multiple addresses/ports. (DEPRECATED: As of 0.2.3.x-alpha, you can now use multiple SOCKSPort entries, and provide addresses for SOCKSPort entries, so SOCKSListenAddress no longer has a purpose. For backward compatibility, SOCKSListenAddress is only allowed when SOCKSPort is just a port number.)

 

It was nice of them to take the time to point this out. They are very busy.

Share this post


Link to post
Posted ... (edited)

Seems like it worked like a charm ! but now i've got another error, see this log.
 

Edit 2 : Firstly, it connected alright and was "Checking" and sunddenly an error and disconnected and now only gives timeout error and doesn't connect anymore. Firstly Tor connected even without AirVPN ON and after i connect air and connected and when was checking, it logged out. Now, nor tor connects, nor air does (via proxy). the logs are the following.
Edit : Recently it keeps giving me only this error

 

23/12/2013 - 15:39 Attempting to establish TCP connection with [AF_INET]127.0.0.1:9150
23/12/2013 - 15:39 TCP connection established with [AF_INET]127.0.0.1:9150
23/12/2013 - 15:39 recv_socks_reply: TCP port read timeout expired
23/12/2013 - 15:39 SIGTERM[soft,init_instance] received, process exiting
23/12/2013 - 15:39 Failed to start.

 

23/12/2013 - 15:28 AirVPN client version: 1,9
23/12/2013 - 15:28 Reading options from C:\Documents and Settings\Any\Desktop\AirVpn\AirVPN.xml
23/12/2013 - 15:28 OpenVPN bundle version: OpenVPN 2.3.2
23/12/2013 - 15:28 OpenVPN current version: OpenVPN 2.3.2
23/12/2013 - 15:28 Login...
23/12/2013 - 15:28 Login success.
23/12/2013 - 15:28 Contacting service...
23/12/2013 - 15:28 Connecting...
23/12/2013 - 15:28 OpenVPN 2.3.2 i686-w64-mingw32 [SSL (OpenSSL)] [LZO] [PKCS11] [eurephia] [IPv6] built on Aug 22 2013
23/12/2013 - 15:28 Socket Buffers: R=[8192->8192] S=[8192->8192]
23/12/2013 - 15:28 Attempting to establish TCP connection with [AF_INET]127.0.0.1:9150
23/12/2013 - 15:28 TCP connection established with [AF_INET]127.0.0.1:9150
23/12/2013 - 15:28 TCPv4_CLIENT link local: [undef]
23/12/2013 - 15:28 TCPv4_CLIENT link remote: [AF_INET]127.0.0.1:9150
23/12/2013 - 15:28 TLS: Initial packet from [AF_INET]127.0.0.1:9150, sid=e33eaf8b bc702d16
23/12/2013 - 15:28 VERIFY OK: depth=1, C=IT, ST=IT, L=Perugia, O=airvpn.org, CN=airvpn.org CA, emailAddress=info@airvpn.org
23/12/2013 - 15:28 VERIFY OK: nsCertType=SERVER
23/12/2013 - 15:28 VERIFY OK: depth=0, C=IT, ST=IT, L=Perugia, O=airvpn.org, CN=server, emailAddress=info@airvpn.org
23/12/2013 - 15:29 Data Channel Encrypt: Cipher 'AES-256-CBC' initialized with 256 bit key
23/12/2013 - 15:29 Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
23/12/2013 - 15:29 Data Channel Decrypt: Cipher 'AES-256-CBC' initialized with 256 bit key
23/12/2013 - 15:29 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
23/12/2013 - 15:29 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 2048 bit RSA
23/12/2013 - 15:29 [server] Peer Connection Initiated with [AF_INET]127.0.0.1:9150
23/12/2013 - 15:29 SENT CONTROL [server]: 'PUSH_REQUEST' (status=1)
23/12/2013 - 15:29 PUSH: Received control message: 'PUSH_REPLY,redirect-gateway def1,dhcp-option DNS 10.7.0.1,comp-lzo no,route xx.x.x.x,topology net30,ping 10,ping-restart 60,ifconfig xx.x.x.xx xx.x.x.xx'
23/12/2013 - 15:29 OPTIONS IMPORT: timers and/or timeouts modified
23/12/2013 - 15:29 OPTIONS IMPORT: LZO parms modified
23/12/2013 - 15:29 OPTIONS IMPORT: --ifconfig/up options modified
23/12/2013 - 15:29 OPTIONS IMPORT: route options modified
23/12/2013 - 15:29 OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified
23/12/2013 - 15:29 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
23/12/2013 - 15:29 open_tun, tt->ipv6=0
23/12/2013 - 15:29 TAP-WIN32 device [Conexão local 3] opened: \\.\Global\{058CB923-EDB0-49B1-921D-6159DD96FB8C}.tap
23/12/2013 - 15:29 TAP-Windows Driver Version 9.9
23/12/2013 - 15:29 Notified TAP-Windows driver to set a DHCP IP/netmask of xx on interface {xxxxx} [DHCP-serv: 10.7.2.65, lease-time: 31536000]
23/12/2013 - 15:29 Successful ARP Flush on interface [4] {058CB923-EDB0-49B1-921D-6159DD96FB8C}
23/12/2013 - 15:29 TEST ROUTES: 2/2 succeeded len=1 ret=1 a=0 u/d=up
23/12/2013 - 15:29 C:\WINDOWS\system32\route.exe ADD xx MASK xxxx
23/12/2013 - 15:29 ROUTE: route addition failed using CreateIpForwardEntry: Parâmetro incorreto.   [status=87 if_index=2]
23/12/2013 - 15:29 Route addition via IPAPI failed [adaptive]
23/12/2013 - 15:29 Route addition fallback to route.exe
23/12/2013 - 15:29 env_block: add PATH=C:\Windows\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
23/12/2013 - 15:29 C:\WINDOWS\system32\route.exe ADD 0.0.0.0 MASK xxx
23/12/2013 - 15:29 Route addition via IPAPI succeeded [adaptive]
23/12/2013 - 15:29 C:\WINDOWS\system32\route.exe ADD xxx MASK xxxx
23/12/2013 - 15:29 Route addition via IPAPI succeeded [adaptive]
23/12/2013 - 15:29 C:\WINDOWS\system32\route.exe ADD xxx MASK xxxx
23/12/2013 - 15:29 Route addition via IPAPI succeeded [adaptive]
23/12/2013 - 15:29 Initialization Sequence Completed
23/12/2013 - 15:29 Starting Management Interface...
23/12/2013 - 15:29 Checking...
23/12/2013 - 15:30 Failed to start.
Edited ... by Night

Share this post


Link to post

Another log if it's going to help, from tor when trying to connect via proxy.

 

23/12/2013 16:37:29.867 [NOTICE] Tried for 120 seconds to get a connection to [scrubbed]:443. Giving up. (waiting for circuit) 
23/12/2013 16:37:29.868 [WARN] Proxy Client: unable to connect to xx("TTL expired") 
23/12/2013 16:37:32.170 [NOTICE] Tried for 120 seconds to get a connection to [scrubbed]:9001. Giving up. (waiting for circuit) 
23/12/2013 16:37:32.190 [WARN] Proxy Client: unable to connect to xx ("TTL expired") 
23/12/2013 16:37:34.919 [NOTICE] Tried for 120 seconds to get a connection to [scrubbed]:9001. Giving up. (waiting for circuit) 
23/12/2013 16:37:34.921 [WARN] Proxy Client: unable to connect to xx ("TTL expired") 
23/12/2013 16:39:33.869 [NOTICE] Tried for 120 seconds to get a connection to [scrubbed]:443. Giving up. (waiting for circuit) 
23/12/2013 16:39:33.870 [WARN] Proxy Client: unable to connect to xxx ("TTL expired") 
23/12/2013 16:39:35.540 [NOTICE] Tried for 121 seconds to get a connection to [scrubbed]:9001. Giving up. (waiting for circuit) 
23/12/2013 16:39:35.550 [WARN] Proxy Client: unable to connect to xxx ("TTL expired")

Share this post


Link to post

Could you connect to AirVPN without Tor?

 

For your AirVPN login:

 

23/12/2013 - 15:30 Failed to start.
23/12/2013 - 15:30 Login...
23/12/2013 - 15:30 Already connected.

 

your session might still be connected (on the server end) but this usually happens with an ungraceful disconnect using UDP. You were using TCP so this shouldn't be the issue but it might be worth checking (if you haven't already). Login to this site and select the 'Client Area' tab. In, 'Current session statistics' see if you are connected, if so, you should have the option to, 'Disconnect Now'. Give it about 10 minutes and try to login to your AirVPN account.

If you are not connected in 'Current session statistics', you might want to open a support ticket with AirVPN. Before opening a ticket, reboot your machine and try (if you haven't already).

For the Tor error, you might need to re-enable connecting to the bridge. Depending on the country you are trying to connect from, that might be the issue.
 

Share this post


Link to post

AirVPN and tor are alright, this error "Already connected" is normal, i just wait 2 minutes and it connect again. The problem is when i try AirVPN over tor socks proxy. You resolved my problem about the authentication, it does not ask me anymore for credentials and in fact, the first time it even connected. i modified torrc-defaults and it connected via proxy, but suddenly it failed (please check the logs on the previous post, i edited it and it shows only the error i've got now, so you can take a better look at it, sorry for the big log and thanks for all the help!). But then, Ok, i got failure and tried again. but, after the first time, everytime i try to connect, it doesn't even connect anymore and gives me this error.  
 

Following AirVPN error log

"23/12/2013 - 15:39 recv_socks_reply: TCP port read timeout expired

23/12/2013 - 15:39 SIGTERM[soft,init_instance] received, process exiting
23/12/2013 - 15:39 Failed to start."

Share this post


Link to post

For this:

23/12/2013 - 15:29 C:\WINDOWS\system32\route.exe ADD 127.0.0.1 MASK 255.255.255.255 192.xxx.xxx.xxx
23/12/2013 - 15:29 ROUTE: route addition failed using CreateIpForwardEntry: Parâmetro incorreto.   [status=87 if_index=2]
23/12/2013 - 15:29 Route addition via IPAPI failed [adaptive]
23/12/2013 - 15:29 C:\WINDOWS\system32\route.exe ADD 0.0.0.0 MASK 128.0.0.0 xxx.xxx.xxx.xxx
23/12/2013 - 15:29 Route addition via IPAPI succeeded [adaptive]

Adding this to the end of the .ovpn file might help:

route-method exe
route-delay 30

but you cannot do this (as far as I know) with AirVPN client.


For this:
23/12/2013 16:37:29.867 [NOTICE] Tried for 120 seconds to get a connection to [scrubbed]:443. Giving up. (waiting for circuit)
23/12/2013 16:37:29.868 [WARN] Proxy Client: unable to connect to xxx.xxx.xxxx.xxxx:443 ("TTL expired")
23/12/2013 16:37:32.170 [NOTICE] Tried for 120 seconds to get a connection to [scrubbed]:9001. Giving up. (waiting for circuit)

It might be an indication that a bridge would help.

For this:

"23/12/2013 - 15:39 recv_socks_reply: TCP port read timeout expired
23/12/2013 - 15:39 SIGTERM[soft,init_instance] received, process exiting
23/12/2013 - 15:39 Failed to start."


I've seen some posts suggesting to use the PreferSOCKSNoAuth which you have done.

The only other thing I can think of (w/ AirVPN client) is to disable your Internet Security on the machine. Perhaps the firewall is interfering? This wouldn't be a resolution or workaround.
Maybe try TCP 443/53 instead of TCP 80 but I don't think that'll help.

Lastly, I'd try installing the OpenVPN GUI wrapper, create a config using the Config Generator and trying it with that.
http://openvpn.net/index.php/download/community-downloads.html
 

In the AirVPN Client Area > Config Generator-

Select your:
1. OS
2. Server

3. Connection Modes:
check Advanced Mode

Select your TCP port

Proxy
Socks
Port 9150

4. Terms of Service
Check those

5. Generate

Place your .ovpn file in the %Program Files%\OpenVPN\config directory

Run OpenVPN GUI with administrative priviledges.

Right-click the OpenVPN GUI applet on the System Tray > go to your (generated) config name > connect.

You can also access your connection log from there.
 

EDIT: If you want to stop DNS and other leaks using OpenVPN, @Nadre posted a method here: https://airvpn.org/topic/9787-the-pros-and-the-cons/?p=11501

 

His post here is about stopping other leaks::

https://airvpn.org/topic/9797-blocking-non-vpn-traffic-without-firewall-using-routing-router/

 

there are also posts within this forum using firewall rules such as this:

https://airvpn.org/topic/3405-windows-comodo-prevent-leaks/

 

for Windows. These would apply to OpenVPN or OpenVPN over Tor, not Tor over OpenVPN.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...